$re = '/(idnotary=)[^\s&]*/';
$str = 'https://www.XXX.it/wp-json/custom-api/notary?title=Marina%20Rossi&wpcf-idnotary=089cy5Ra9zE=&wpcf-nome-notary=Marina....................
';
$subst = "$1replacement";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;