// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(idnotary=)[^\s&]*").unwrap();
let string = "https://www.XXX.it/wp-json/custom-api/notary?title=Marina%20Rossi&wpcf-idnotary=089cy5Ra9zE=&wpcf-nome-notary=Marina....................
";
let substitution = "$1replacement";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}