#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[START\]client\.(?<type>\w+)\n(?<value>.*)\n\[END\]client\.\w+$"
Local $sString = "[START]client.mail" & @CRLF & _
"exemple@exemple.com" & @CRLF & _
"[END]client.mail" & @CRLF & _
"[START]client.ville" & @CRLF & _
"Marseille" & @CRLF & _
"[END]client.ville"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")