package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[START\]client\.(?<type>\w+)\n(?<value>.*)\n\[END\]client\.\w+$`)
var str = `[START]client.mail
exemple@exemple.com
[END]client.mail
[START]client.ville
Marseille
[END]client.ville`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}