$re = '/^\[START\]client\.(?<type>\w+)\n(?<value>.*)\n\[END\]client\.\w+$/m';
$str = '[START]client.mail
exemple@exemple.com
[END]client.mail
[START]client.ville
Marseille
[END]client.ville';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);