#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!database|audit|index|analysis|extract|good|bad).*$"
Local $sString = "database" & @CRLF & _
"audit" & @CRLF & _
"index" & @CRLF & _
"analysis" & @CRLF & _
"extract" & @CRLF & _
"good" & @CRLF & _
"bad" & @CRLF & _
"hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")