import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!database|audit|index|analysis|extract|good|bad).*$";
final String string = "database\n"
+ "audit\n"
+ "index\n"
+ "analysis\n"
+ "extract\n"
+ "good\n"
+ "bad\n"
+ "hello";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}