re = /^(?!database|audit|index|analysis|extract|good|bad).*$/m
str = 'database
audit
index
analysis
extract
good
bad
hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end