#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\h*(Impact:)\s+(.*)|^\h+(Severity:)\s+(.*)"
Local $sString = "Project: Joomla!" & @CRLF & _
" SubProject: CMS" & @CRLF & _
" Impact: Low" & @CRLF & _
" Severity: Low" & @CRLF & _
" Versions: 3.6.0 - 3.9.12" & @CRLF & _
" Exploit type: Path Disclosure" & @CRLF & _
" Reported Date: 2019-November-01" & @CRLF & _
" Fixed Date: 2019-November-05" & @CRLF & _
" CVE Number: CVE-2019-18674" & @CRLF & _
"" & @CRLF & _
"Description" & @CRLF & _
"" & @CRLF & _
"Missing access check in the phputf8 mapping files could lead to an path disclosure." & @CRLF & _
"Affected Installs" & @CRLF & _
"" & @CRLF & _
"Joomla! CMS versions 3.6.0 - 3.9.12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")