# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\h*(Impact:)\s+(.*)|^\h+(Severity:)\s+(.*)"
test_str = ("Project: Joomla!\n"
" SubProject: CMS\n"
" Impact: Low\n"
" Severity: Low\n"
" Versions: 3.6.0 - 3.9.12\n"
" Exploit type: Path Disclosure\n"
" Reported Date: 2019-November-01\n"
" Fixed Date: 2019-November-05\n"
" CVE Number: CVE-2019-18674\n\n"
"Description\n\n"
"Missing access check in the phputf8 mapping files could lead to an path disclosure.\n"
"Affected Installs\n\n"
"Joomla! CMS versions 3.6.0 - 3.9.12")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.