use strict;
my $str = 'Project: Joomla!
SubProject: CMS
Impact: Low
Severity: Low
Versions: 3.6.0 - 3.9.12
Exploit type: Path Disclosure
Reported Date: 2019-November-01
Fixed Date: 2019-November-05
CVE Number: CVE-2019-18674
Description
Missing access check in the phputf8 mapping files could lead to an path disclosure.
Affected Installs
Joomla! CMS versions 3.6.0 - 3.9.12';
my $regex = qr/^\h*(Impact:)\s+(.*)|^\h+(Severity:)\s+(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}