import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h*(Impact:)\\s+(.*)|^\\h+(Severity:)\\s+(.*)";
final String string = "Project: Joomla!\n"
+ " SubProject: CMS\n"
+ " Impact: Low\n"
+ " Severity: Low\n"
+ " Versions: 3.6.0 - 3.9.12\n"
+ " Exploit type: Path Disclosure\n"
+ " Reported Date: 2019-November-01\n"
+ " Fixed Date: 2019-November-05\n"
+ " CVE Number: CVE-2019-18674\n\n"
+ "Description\n\n"
+ "Missing access check in the phputf8 mapping files could lead to an path disclosure.\n"
+ "Affected Installs\n\n"
+ "Joomla! CMS versions 3.6.0 - 3.9.12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}