using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|[^\w&+'])(?=[\w&+']*\w)\K|\G[\w&+']*\w[\w&+']*\K";
string input = @"This is a +sentence& &&with++ such words.
It doesn't treat + or &&&+++ as words.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}