$re = '/(?:^|[^\w&+\'])(?=[\w&+\']*\w)\K|\G[\w&+\']*\w[\w&+\']*\K/m';
$str = 'This is a +sentence& &&with++ such words.
It doesn\'t treat + or &&&+++ as words.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);