re = /(?:^|[^\w&+'])(?=[\w&+']*\w)\K|\G[\w&+']*\w[\w&+']*\K/m
str = 'This is a +sentence& &&with++ such words.
It doesn\'t treat + or &&&+++ as words.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end