import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{\".+)\\)";
final String string = "<script>\n"
+ " Classify(\"cs.services/GlobalObject\").set(\"responseJson\",{\"DISPUTE_MESSAGE\":\"Test\",\"results\":[{\"resultText\":\"LALALA.\"},{\"resultText\":\"TEXT HERE\"},{\"resultText\":\"123\"}],\"STATUS\":\"OK\",\"REG\":\"Y\", \"Info\":{\"text\":\"123\",\"text2\":\"3\",\"image\":\"url\",\"id\":\"12345\"}});\n"
+ " Classify(\"cs.services/GlobalObject\").set(\"responseJson.LINK_URL\",\"/us/en/\");\n"
+ " Classify(\"cs.services/GlobalObject\").set(\"callerId\",\"ccweb\");\n"
+ " </script>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}