using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Request .*?>\s*<(?<tagname>.*?)>";
string input = @"<?xml version=""1.0"" encoding=""UTF-8""?>
<Request xmlns=""urn:x-google-com:ABC.plan.services.test""><OneRequest><page_number>1</page_number><page_size>25</page_size><origin>TEST</origin><item_name/></OneRequest></Request>
<Request xmlns=""urn:x-google-com:ABC.plan.services.test"">
<SecondRequest/>
</Request>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}