use strict;
my $str = '<?xml version="1.0" encoding="UTF-8"?>
<Request xmlns="urn:x-google-com:ABC.plan.services.test"><OneRequest><page_number>1</page_number><page_size>25</page_size><origin>TEST</origin><item_name/></OneRequest></Request>
<Request xmlns="urn:x-google-com:ABC.plan.services.test">
<SecondRequest/>
</Request>';
my $regex = qr/<Request .*?>\s*<(?<tagname>.*?)>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}