// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<Request .*?>\s*<(?<tagname>.*?)>").unwrap();
let string = "<?xml version=\"1.0\" encoding=\"UTF-8\"?>
<Request xmlns=\"urn:x-google-com:ABC.plan.services.test\"><OneRequest><page_number>1</page_number><page_size>25</page_size><origin>TEST</origin><item_name/></OneRequest></Request>
<Request xmlns=\"urn:x-google-com:ABC.plan.services.test\">
<SecondRequest/>
</Request>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}