using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<color>((?!black).*?|black.+?)</color>$";
string input = @"How do I write a regex expression that matches these lines
<color>blue</color>
<color>green</color>
<color>black</color>
<color>blackish</color>
<color>offblack</color>
:)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}