import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<color>((?!black).*?|black.+?)</color>$";
final String string = "How do I write a regex expression that matches these lines\n\n"
+ "<color>blue</color>\n"
+ "<color>green</color>\n"
+ "<color>black</color>\n"
+ "<color>blackish</color>\n"
+ "<color>offblack</color>\n\n"
+ ":)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}