const regex = new RegExp('^<color>((?!black).*?|black.+?)</color>$', 'gm')
const str = `How do I write a regex expression that matches these lines
<color>blue</color>
<color>green</color>
<color>black</color>
<color>blackish</color>
<color>offblack</color>
:)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}