re = /^<color>((?!black).*?|black.+?)<\/color>$/m
str = 'How do I write a regex expression that matches these lines
<color>blue</color>
<color>green</color>
<color>black</color>
<color>blackish</color>
<color>offblack</color>
:)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end