use strict;
my $str = 'String line = "<p class=MsoNormal align=center style=\'margin-bottom:0cm;margin-bottom:.0001pt;text-align:center;line-height:normal\'><img width=165 height=128 src=image001.jpg/></p>"';
my $regex = qr/<img[^>]+>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}