re = /<img[^>]+>/
str = 'String line = "<p class=MsoNormal align=center style=\'margin-bottom:0cm;margin-bottom:.0001pt;text-align:center;line-height:normal\'><img width=165 height=128 src=image001.jpg/></p>"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end