#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(www\.)?\b(?!google\.com|system.net)[-a-zA-Z0-9@:%._\+~#=]{2,256}\.(com|net|info)\b([-a-zA-Z0-9@:%_\+.~#?&\/=]*)"
Local $sString = "Regex to find URLs unless they include a list of strings (Visual Studio search)" & @CRLF & _
"I have this the following expression which is working well for my needs:" & @CRLF & _
"" & @CRLF & _
"(www\.)?[-a-zA-Z0-9@:%._\+~#=]{2,256}\.(com|net|info)\b([-a-zA-Z0-9@:%_\+.~#?&//=]*) " & @CRLF & _
"It does a pretty good job of finding URLs which are hardcoded in a large codebase. Obviously, it has some false positives for things like Using System.net, but some of the valid URLs don't include http(s):// unfortunately." & @CRLF & _
"" & @CRLF & _
"So now I want to be able to exclude certain things, including system.net (false positives) and google.com (common urls in comments)." & @CRLF & _
"" & @CRLF & _
"How can I do this?" & @CRLF & _
"" & @CRLF & _
"Ideally the list would just include google and system. Something like (!google|!system)." & @CRLF & _
"" & @CRLF & _
"https://thisisaurl.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")