re = /(www\.)?\b(?!google\.com|system.net)[-a-zA-Z0-9@:%._\+~#=]{2,256}\.(com|net|info)\b([-a-zA-Z0-9@:%_\+.~#?&\/=]*)/mi
str = 'Regex to find URLs unless they include a list of strings (Visual Studio search)
I have this the following expression which is working well for my needs:
(www\\.)?[-a-zA-Z0-9@:%._\\+~#=]{2,256}\\.(com|net|info)\\b([-a-zA-Z0-9@:%_\\+.~#?&//=]*)
It does a pretty good job of finding URLs which are hardcoded in a large codebase. Obviously, it has some false positives for things like Using System.net, but some of the valid URLs don\'t include http(s):// unfortunately.
So now I want to be able to exclude certain things, including system.net (false positives) and google.com (common urls in comments).
How can I do this?
Ideally the list would just include google and system. Something like (!google|!system).
https://thisisaurl.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end