import Foundation
let pattern = ##"(www\.)?\b(?!google\.com|system.net)[-a-zA-Z0-9@:%._\+~#=]{2,256}\.(com|net|info)\b([-a-zA-Z0-9@:%_\+.~#?&\/=]*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
Regex to find URLs unless they include a list of strings (Visual Studio search)
I have this the following expression which is working well for my needs:
(www\.)?[-a-zA-Z0-9@:%._\+~#=]{2,256}\.(com|net|info)\b([-a-zA-Z0-9@:%_\+.~#?&//=]*)
It does a pretty good job of finding URLs which are hardcoded in a large codebase. Obviously, it has some false positives for things like Using System.net, but some of the valid URLs don't include http(s):// unfortunately.
So now I want to be able to exclude certain things, including system.net (false positives) and google.com (common urls in comments).
How can I do this?
Ideally the list would just include google and system. Something like (!google|!system).
https://thisisaurl.com/
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)