use strict;
my $str = 'Regex to find URLs unless they include a list of strings (Visual Studio search)
I have this the following expression which is working well for my needs:
(www\\.)?[-a-zA-Z0-9@:%._\\+~#=]{2,256}\\.(com|net|info)\\b([-a-zA-Z0-9@:%_\\+.~#?&//=]*)
It does a pretty good job of finding URLs which are hardcoded in a large codebase. Obviously, it has some false positives for things like Using System.net, but some of the valid URLs don\'t include http(s):// unfortunately.
So now I want to be able to exclude certain things, including system.net (false positives) and google.com (common urls in comments).
How can I do this?
Ideally the list would just include google and system. Something like (!google|!system).
https://thisisaurl.com/';
my $regex = qr/(www\.)?\b(?!google\.com|system.net)[-a-zA-Z0-9@:%._\+~#=]{2,256}\.(com|net|info)\b([-a-zA-Z0-9@:%_\+.~#?&\/=]*)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}