#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)Listing(.+?)(?=\n)"
Local $sString = " SUSTAINABLE HARVEST SECTOR | QUOTA LISTING JUN 11 2013" & @CRLF & _
"2 QUOTA" & @CRLF & _
"3 TRADE ID AVAILABLE STOCK AMOUNT PRICE" & @CRLF & _
"4 130196 COD GBW 10,000 $0.60" & @CRLF & _
"5 130158 HADDOCK GBE 300 $0.60"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")