re = /Listing(.+?)(?=\n)/i
str = ' SUSTAINABLE HARVEST SECTOR | QUOTA LISTING JUN 11 2013
2 QUOTA
3 TRADE ID AVAILABLE STOCK AMOUNT PRICE
4 130196 COD GBW 10,000 $0.60
5 130158 HADDOCK GBE 300 $0.60'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end