import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Listing(.+?)(?=\\n)";
final String string = " SUSTAINABLE HARVEST SECTOR | QUOTA LISTING JUN 11 2013\n"
+ "2 QUOTA\n"
+ "3 TRADE ID AVAILABLE STOCK AMOUNT PRICE\n"
+ "4 130196 COD GBW 10,000 $0.60\n"
+ "5 130158 HADDOCK GBE 300 $0.60";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}