import re
regex = re.compile(r"Listing(.+?)(?=\n)", flags=re.IGNORECASE)
test_str = (" SUSTAINABLE HARVEST SECTOR | QUOTA LISTING JUN 11 2013\n"
"2 QUOTA\n"
"3 TRADE ID AVAILABLE STOCK AMOUNT PRICE\n"
"4 130196 COD GBW 10,000 $0.60\n"
"5 130158 HADDOCK GBE 300 $0.60")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")