import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<time>\\d{2}:\\d{2}:\\d{2} \\d{2}-\\d{2}-\\d{4}) (?P<error_message>.*) Le moteur semble ne plus repondre depuis.*$";
final String string = "09:50:14 16-06-2020 | th-1cc94740 | 01 | Tengine.c 371 | Le moteur semble ne plus repondre depuis 30 minutes";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}