re = /^(?P<time>\d{2}:\d{2}:\d{2} \d{2}-\d{2}-\d{4}) (?P<error_message>.*) Le moteur semble ne plus repondre depuis.*$/m
str = '09:50:14 16-06-2020 | th-1cc94740 | 01 | Tengine.c 371 | Le moteur semble ne plus repondre depuis 30 minutes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end