const regex = new RegExp('^(?P<time>\\d{2}:\\d{2}:\\d{2} \\d{2}-\\d{2}-\\d{4}) (?P<error_message>.*) Le moteur semble ne plus repondre depuis.*$', 'gm')
const str = `09:50:14 16-06-2020 | th-1cc94740 | 01 | Tengine.c 371 | Le moteur semble ne plus repondre depuis 30 minutes`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}