// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<time>\d{2}:\d{2}:\d{2} \d{2}-\d{2}-\d{4}) (?P<error_message>.*) Le moteur semble ne plus repondre depuis.*$").unwrap();
let string = "09:50:14 16-06-2020 | th-1cc94740 | 01 | Tengine.c 371 | Le moteur semble ne plus repondre depuis 30 minutes";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}