#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d+(?:(?:\.|,)\d{3})*(?:(?:\.|,)\d{2})\b(?!\W\d)"
Local $sString = "Beschreibung Menge VK-Preis MwSt% Betrag" & @CRLF & _
"Schadenbewertunginkl.Restwertermittlung 1 25,00€ 19 25,00€" & @CRLF & _
"Rechnungsbetragexcl.MwSt.: 25,00€" & @CRLF & _
"MwSt.(19%): 4,75€" & @CRLF & _
"Rechnungsbetragincl.MwSt.: 123.029,75€" & @CRLF & _
"Gutachtennummer: 1009126 Leistungsdatum: 11.10.2021" & @CRLF & _
"$12.55"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")