import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d+(?:(?:\\.|,)\\d{3})*(?:(?:\\.|,)\\d{2})\\b(?!\\W\\d)";
final String string = "Beschreibung Menge VK-Preis MwSt% Betrag\n"
+ "Schadenbewertunginkl.Restwertermittlung 1 25,00€ 19 25,00€\n"
+ "Rechnungsbetragexcl.MwSt.: 25,00€\n"
+ "MwSt.(19%): 4,75€\n"
+ "Rechnungsbetragincl.MwSt.: 123.029,75€\n"
+ "Gutachtennummer: 1009126 Leistungsdatum: 11.10.2021\n"
+ "$12.55";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}