re = /\b\d+(?:(?:\.|,)\d{3})*(?:(?:\.|,)\d{2})\b(?!\W\d)/m
str = 'Beschreibung Menge VK-Preis MwSt% Betrag
Schadenbewertunginkl.Restwertermittlung 1 25,00€ 19 25,00€
Rechnungsbetragexcl.MwSt.: 25,00€
MwSt.(19%): 4,75€
Rechnungsbetragincl.MwSt.: 123.029,75€
Gutachtennummer: 1009126 Leistungsdatum: 11.10.2021
$12.55'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end