# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b\d+(?:(?:\.|,)\d{3})*(?:(?:\.|,)\d{2})\b(?!\W\d)"
test_str = ("Beschreibung Menge VK-Preis MwSt% Betrag\n"
"Schadenbewertunginkl.Restwertermittlung 1 25,00€ 19 25,00€\n"
"Rechnungsbetragexcl.MwSt.: 25,00€\n"
"MwSt.(19%): 4,75€\n"
"Rechnungsbetragincl.MwSt.: 123.029,75€\n"
"Gutachtennummer: 1009126 Leistungsdatum: 11.10.2021\n"
"$12.55")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.