using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ref=""[^""\r\n]*""";
string input = @"[show_portfolio get=""yachts"" for=""sale"" in=""europe"" sort=""length_overall"" by=""asc"" page=""1"" perpage=""18"" theme=""active-71"" ref=""http://replaceme.com"" debug=""true"" engine=""engine.com""]
[get_portfolio get=""yachts"" for=""sale"" in=""europe"" sort=""length_overall"" by=""asc"" page=""1"" perpage=""18"" theme=""active-71"" ref=""http://replaceme.com"" debug=""true"" engine=""engine.com""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}