import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ref=\"[^\"\\r\\n]*\"";
final String string = "[show_portfolio get=\"yachts\" for=\"sale\" in=\"europe\" sort=\"length_overall\" by=\"asc\" page=\"1\" perpage=\"18\" theme=\"active-71\" ref=\"http://replaceme.com\" debug=\"true\" engine=\"engine.com\"]\n"
+ " \n"
+ " [get_portfolio get=\"yachts\" for=\"sale\" in=\"europe\" sort=\"length_overall\" by=\"asc\" page=\"1\" perpage=\"18\" theme=\"active-71\" ref=\"http://replaceme.com\" debug=\"true\" engine=\"engine.com\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}