import re
regex = re.compile(r"ref=\"[^\"\r\n]*\"", flags=re.MULTILINE)
test_str = ("[show_portfolio get=\"yachts\" for=\"sale\" in=\"europe\" sort=\"length_overall\" by=\"asc\" page=\"1\" perpage=\"18\" theme=\"active-71\" ref=\"http://replaceme.com\" debug=\"true\" engine=\"engine.com\"]\n"
" \n"
" [get_portfolio get=\"yachts\" for=\"sale\" in=\"europe\" sort=\"length_overall\" by=\"asc\" page=\"1\" perpage=\"18\" theme=\"active-71\" ref=\"http://replaceme.com\" debug=\"true\" engine=\"engine.com\"]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")