#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([0-2]+\d[0-5]?|[1]\d?\d+|[1-9][0-9])\.([0-2]?\d[0-5]?|[1]\d?\d+|[1-9][0-9])\.([0-2]?\d[0-5]?|[1]\d?\d+|[1-9][0-9])\.([0-2]?\d[0-5]?|[1]\d?\d+|[1-9][0-9])$"
Local $sString = "212.88.197.8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")