import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-2]+\\d[0-5]?|[1]\\d?\\d+|[1-9][0-9])\\.([0-2]?\\d[0-5]?|[1]\\d?\\d+|[1-9][0-9])\\.([0-2]?\\d[0-5]?|[1]\\d?\\d+|[1-9][0-9])\\.([0-2]?\\d[0-5]?|[1]\\d?\\d+|[1-9][0-9])$";
final String string = "212.88.197.8";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}