re = /^([0-2]+\d[0-5]?|[1]\d?\d+|[1-9][0-9])\.([0-2]?\d[0-5]?|[1]\d?\d+|[1-9][0-9])\.([0-2]?\d[0-5]?|[1]\d?\d+|[1-9][0-9])\.([0-2]?\d[0-5]?|[1]\d?\d+|[1-9][0-9])$/
str = '212.88.197.8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end