#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ui)(?<=^|$|[\s,\/-])(?:(?P<var1>(?<![\/-])(?!(?:(\d+(?:[,.][05])?)[\/-]){2}(?-1))(\d+(?:[,.][05])?)[\/-](?-1)|(?-1)))(?=^|$|[\s,\/-])"
Local $sString = "32/34, 36/38, 40/42, 44/46" & @CRLF & _
"40/42/44/46/48" & @CRLF & _
"58/60" & @CRLF & _
"39-42" & @CRLF & _
"40-50-60" & @CRLF & _
"24-25,26,28,30" & @CRLF & _
"36 40,5 44" & @CRLF & _
""
Local $sSubst = "\g<var1>\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)