import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|$|[\\s,\\/-])(?:(?P<var1>(?<![\\/-])(?!(?:(\\d+(?:[,.][05])?)[\\/-]){2}(?-1))(\\d+(?:[,.][05])?)[\\/-](?-1)|(?-1)))(?=^|$|[\\s,\\/-])";
final String string = "32/34, 36/38, 40/42, 44/46\n"
+ "40/42/44/46/48\n"
+ "58/60\n"
+ "39-42\n"
+ "40-50-60\n"
+ "24-25,26,28,30\n"
+ "36 40,5 44\n";
final String subst = "\\g<var1>\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}