re = /(?<=^|$|[\s,\/-])(?:(?P<var1>(?<![\/-])(?!(?:(\d+(?:[,.][05])?)[\/-]){2}(?-1))(\d+(?:[,.][05])?)[\/-](?-1)|(?-1)))(?=^|$|[\s,\/-])/i
str = '32/34, 36/38, 40/42, 44/46
40/42/44/46/48
58/60
39-42
40-50-60
24-25,26,28,30
36 40,5 44
'
subst = '\\g<var1>\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result